using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?: # Start of line and alternation group
.*[[{(«][^\]})»\n]* # un-closed
|
[^[{(«\n]*[\]})»].* # never opened
|
.*\w[[{(«].* # opened mid-word
|
.*[\]})»]\w.* # closed mid-word
)$ # End of line and alternation group";
string input = @"// i want to mark for single brackets examples below other heighlight pattren not disturb.please
(weather // i want to mark this word
weather) // i want to mark this word
(weather is good // i want to mark this word
weather is good) // i want to mark this word
weathe)r
wea(ther
and same for other brackets {,[,«
{weather // i want to mark this word
weather} // i want to mark this word
{weather is good // i want to mark this word
weather is good} // i want to mark this word
weathe}r // i want to mark this word
weathe{r // i want to mark this word
[weather // i want to mark this word
weather] // i want to mark this word
[weather is good // i want to mark this word
weather is good] // i want to mark this word
weathe]r // i want to mark this word
weathe[r // i want to mark this word
«weather // i want to mark this word
weather} // i want to mark this word
«weather is good // i want to mark this word
weather is good» // i want to mark this word
weathe»r // i want to mark this word
weathe»r // i want to mark this word
(Weather) is good. // not need to mark this beacuase this word correct word
Weath(er) is good. // mark
Weath(er is good). // mark
Weather (is) (good).
My name is Rah(eel) // mark
Best pro(duct) // mark
(Weather is good) // not need to mark this beacuase this word konown word
we(ather)
(weath)er is good. // mark
(weath)er // mark
weather(is fine)
weather is good
{weather is good} //not need to mark correct
weat{er is good} // mark
we{ather} is fine // mark
{weathe}r is fine // i want to mark this word
{weather is fin}e // i want to mark this word
[weather is good] //not need to mark correct
weat[her is good] // mark
we[ather] is fine // mark
[weathe]r is fine // mark
[weather is f]ine // mark
we[ather] is fine // mark
«weather is good» //not need to mark
weat«her is good» // mark
we«ather» is fine // mark
«weat»her is fine // mark
«weather is fi»ne // mark
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}