const regex = new RegExp('^((?:https?://(?:www\\.)?|www\\.)(?:(?!-)[A-Za-z0-9-]+\\.[a-z]+)(?:\\/[A-Za-z0-9-_]+\\/?)*(?:[?&][A-Za-z0-9-\\=\\+_]+)*(?:\\.[a-z]+)*)$|^((?:\\d{1,3}\\.){3}\\d{1,3}(?:\\:\\d+)?)$', 'gm')
const str = `http://www.google.com
http://google.com
https://www.google.com
https://google.com
www.abcdefghijklmnopqrstuvwxyz123456789-.com
http://www.abcdefghijklmnopqrstuvwxyz123456789-.com
https://www.crummy.com/software/wow/
https://www.crummy.com/software?wow=1
https://www.crummy.com/software/examples/hello?wow=1&yep=ok
https://www.crummy.com/software?wow=1+and+2&yep=ok
https://www.crummy.com/software/BeautifulSoup/bs4/doc/_sources/index.txt
Outliers
http://www.google
http://wwww.google.com
http://ww.google.com
https://w.g.c
255.255.255.255:5555
192.168.9.50:22
127.0.0.1
127.0.0.1:8080
www.google
google.com
google
ww.google.c
ht://www.google.com
www.-google.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}