import re
regex = re.compile(r"(?<=name is )(.*)(?=,)", flags=re.MULTILINE)
test_str = "is, My name is Sir John watson Bler, and I am a developer. Is it ok?"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")