$re = '/"competition_id":(\d+)/';
$str = '<script type="text/javascript" charset="utf-8">
(function() {
var block = new MatchesBlock(\'page_team_1_block_team_matches_summary_7\', \'block_team_matches_summary\', {"page":0,"bookmaker_urls":[],"block_service_id":"team_summary_block_teammatchessummary","team_id":1242,"competition_id":0,"filter":"all","new_design":false});
block.registerForCallbacks();
block.addCallbackObserver(\'page_team_1_block_team_matches_summary_7_1_1\', \'changeCompetition\', {"competition_id":0});
block.addCallbackObserver(\'page_team_1_block_team_matches_summary_7_1_2\', \'changeCompetition\', {"competition_id":13});
block.addCallbackObserver(\'page_team_1_block_team_matches_summary_7_1_3\', \'changeCompetition\', {"competition_id":135});
block.addCallbackObserver(\'page_team_1_block_team_matches_summary_7_1_4\', \'changeCompetition\', {"competition_id":171});
block.addCallbackObserver(\'page_team_1_block_team_matches_summary_7_1_5\', \'changeCompetition\', {"competition_id":1148});
block.addCallbackObserver(\'page_team_1_block_team_matches_summary_7_1_6\', \'changeCompetition\', {"competition_id":732});
block.addCallbackObserver(\'page_team_1_block_team_matches_summary_7_1_7\', \'changeCompetition\', {"competition_id":10});
block.addCallbackObserver(\'page_team_1_block_team_matches_summary_7_2_1\', \'filterMatches\', {"filter":"all"});
block.addCallbackObserver(\'page_team_1_block_team_matches_summary_7_2_2\', \'filterMatches\', {"filter":"home"});
block.addCallbackObserver(\'page_team_1_block_team_matches_summary_7_2_3\', \'filterMatches\', {"filter":"away"});
block.setAttribute(\'colspan_left\', 4);
block.setAttribute(\'colspan_right\', 3);
block.setAttribute(\'has_previous_page\', true);
block.setAttribute(\'has_next_page\', true);
TimestampFormatter.format(\'page_team_1_block_team_matches_summary_7\');
})();
</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);