$re = '/(?:(?<=^)|(?<=\n))\s*Parameter.*/';
$str = 'Parameter: A
%Parameter: B
% Parameter: C
Parameter: D %the best parameter';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);