$re = '/[1-9][0-9]+$/m';
$str = 'c0001230
f0000546
y0098061
h0064125
a0000030';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);