$re = '/^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])\S.{6,}$/m';
$str = 'abc$1f';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);