$re = '/<i>(foo \d+\s*(?:(?!\(bar\)).)*)(\(bar\))?/m';
$str = '<i>foo 42 </i> <i>(bar)</i>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);