re = /<i>(foo \d+\s*(?:(?!\(bar\)|foo \d).)*)(\(bar\))?/m
str = '<i>foo 42 </i> <i>(bar)</i>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end