$re = '/A[-+]?(?:[0-9]*\.?(?:[0-9]+)?)/m';
$str = 'A50. hsih Y0 his ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);