import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(?:\\,[\\r\\n]*\\d+)*";
final String string = "123,\n"
+ "456,\n"
+ "345\n\n\n"
+ "123,234,456\n\n\n"
+ "123,\n"
+ "234,\n"
+ "456,789 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}