re = /\|\K(?=.{1,253}\|)(?!.*--.*)(?P<fqdn>(?:(?!-)(?![0-9])[a-zA-Z0-9-]{1,63}(?<!-)\.){1,}(?:(?!-)[a-zA-Z0-9-]{1,63}(?<!-)))\|/m
str = '|abc123-bar-qwerty.foo.com|
|foo.bar|
|foo.bar.com|
|foo--bar.com|
|aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.63|
|aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.64|
|aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.a.253|
|aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aa.254|
|1.2.3.4.5.6.7.8.9.10.11.12.13|
|1.2.3.4.5.6.7.8.9.10.11.12.13.14|
|133tfoo.bar.com|
|foo|
|foo.|
|foo.bar.|
|foo-|
|foo-.|
|foo-.bar|
|foo-.bar.|
|foo-.bar-.com|
|.foo-bar|
|foo-bar|
|foo-.bar|
|-foo-bar|
|--foo-bar|
|foo--bar|
|foo-bar.|'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end