#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".+left X:..(.+?)\n.+Y:..(.+?)\n.+\n.+\n.+:.(.+?)\n.+:.(.+?)\n"
Local $sString = "" & @CRLF & _
"xwininfo: Window id: 0x4800024 "Yebe"" & @CRLF & _
"" & @CRLF & _
" Absolute upper-left X: 100" & @CRLF & _
" Absolute upper-left Y: 164" & @CRLF & _
" Relative upper-left X: 10" & @CRLF & _
" Relative upper-left Y: 45" & @CRLF & _
" Width: 1600" & @CRLF & _
" Height: 1200" & @CRLF & _
" Depth: 24" & @CRLF & _
" Visual: 0x6e" & @CRLF & _
" Visual Class: DirectColor" & @CRLF & _
" Border width: 0" & @CRLF & _
" Class: InputOutput" & @CRLF & _
" Colormap: 0x4800022 (not installed)" & @CRLF & _
" Bit Gravity State: ForgetGravity" & @CRLF & _
" Window Gravity State: NorthWestGravity" & @CRLF & _
" Backing Store State: NotUseful" & @CRLF & _
" Save Under State: no" & @CRLF & _
" Map State: IsViewable" & @CRLF & _
" Override Redirect State: no" & @CRLF & _
" Corners: +100+164 -860+164 -860-76 +100-76" & @CRLF & _
" -geometry 1600x1200+90-66"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")