const regex = /\s*(?<!\S)([^:]+)\s*:(\S+)(?!\S)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(?<!\\S)([^:]+)\\s*:(\\S+)(?!\\S)', 'g')
const str = `id:pgl01130529155035239084 sub:001 dlvrd:001 submit date:1305291550 done date:1305291550 stat:DELIVRD err:0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}