package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` \((\d+)\)$`)
var str = `test (33)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}