const regex = /\$\{(\w+)\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$\\{(\\w+)\\}', 'g')
const str = `for(var i=0;i<\${MyVar}.length;i++){ alert(\${MyVar}[i]); if(\${FooBar}) { \${Bazz}(); } }`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);