$re = '/^\s*|\s*,\s*|\s*,?\s*$/';
$str = ' foo, bar, no match, ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);