import re
regex = re.compile(r"^(?<timestamp>[^ ]*)\.(?<time_microseconds>\d*)\+[^ ]+ (?<host>[^ ]*) postgres\[(?<pid>\d*)\]: \[(?<groupid>[^ ]\d*)-(?<lineid>[^ ]\d*)\](?<message>.*)$", flags=re.MULTILINE)
test_str = ("2017-03-21T03:01:32.627434+00:00 ec317 postgres[82271]: [134-1] 2017-03-21 03:01:32 UTC [82271]: [2-1] user=unknown db=[unknown] LOG: incomplete startup packet\n"
"2017-03-21T03:01:32.761669+00:00 ec317 postgres[82270]: [135-1] 2017-03-21 03:01:32 UTC [82270]: [3-1] user=gz_kettle,db=greenzone LOG: disconnection: session time: 0:00:00.182 user=gz_kettle database=greenzone host=172.26.27.22 port=35849\n"
"2017-03-21T03:01:32.800403+00:00 ec317 postgres[82272]: [133-1] 2017-03-21 03:01:32 UTC [82272]: [1-1] user=[unknown],db=[unknown] LOG: connection received: host=172.26.27.22 port=35850\n"
"2017-03-21T03:01:32.801596+00:00 ec317 postgres[82272]: [134-1] 2017-03-21 03:01:32 UTC [82272]: [2-1] user=gz_kettle,db=greenzone LOG: connection authorized: user=gz_kettle database=greenzone")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")