using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/\Kexample\.com";
string substitution = @"abc.host.prov.com";
string input = @"<img class=""aligncenter wp-image-27283 size-large"" src=""http://example.com/wp-content/uploads/2017/04/image-3-1024x1024.jpeg"" alt=""homemade chocolate recipe"" width=""640"" height=""640"" srcset=""http://example.com/wp-content/uploads/2017/04/image-3-1024x1024.jpeg 1024w, http://example.com/wp-content/uploads/2017/04/image-3-300x300.jpeg 300w, http://example.com/wp-content/uploads/2017/04/image-3-768x768.jpeg 768w, http://example.com/wp-content/uploads/2017/04/image-3-696x696.jpeg 696w, http://example.com/wp-content/uploads/2017/04/image-3-1068x1068.jpeg 1068w, http://example.com/wp-content/uploads/2017/04/image-3-420x420.jpeg 420w, http://example.com/wp-content/uploads/2017/04/image-3-560x560.jpeg 560w, http://example.com/wp-content/uploads/2017/04/image-3.jpeg 1080w"" sizes=""(max-width: 640px) 100vw, 640px"" />";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}