$re = '/(^(?P<line_num>[1-9]|1[0-9]|2[0-2])\b +)(?P<qa_type>(Q|A|[mM][rR][\.|:]? [a-zA-Z]+|[mM][rR][sS][\.|:]? [a-zA-Z]+|[mM][sS][\.|:]? [a-zA-Z]+|[mM][iI][sS][sS][\.|:]? [a-zA-Z]+|[dD][rR][\.|:]? [a-zA-Z]+))?([\.|:|\s]+)?(?P<type_text>\b.*)|[pP][aA][gG][eE] (?P<page_num>\d{1,3})/m';
$str = '1 sure I understand, in this figure, the bottom figure
2 below Paragraph 88 that you prepared, to describe
3 your combination of Mendelson \'799/Ohsaki, is it
4 intended to show the relative sizes of the various
5 components?
6 MR. SMITH: Objection; form.
7 A. No. I\'d say it\'s purely an
8 illustration to convey the concept of how one might
9 combined these elements in order to achieve the
10 benefits we\'ve spoken of, using the convex cover to
11 provide improved adhesion and improved -- I might as
12 well read from the declaration -- "improved adhesion
13 and detection and protection of the elements within."
14 Q. Okay. And if a sensor like the one
15 you showed in the bottom figure below Paragraph 88
16 were used to take a physiological measurement, do you
17 agree that the distribution of incoming light would
18 be different as compared to the same sensor with no
19 cover?
20 MR. SMITH: Objection; form.
21 A. Yes, I agree that the convex cover
22 creates refractive effects, which change the angles
4/25/2021 [Redacted Text] Vol II
www.[Redacted Text].com [Redacted Text] 2021 [Redacted Text]
Page 275
1 of propagation of the rays of light. We are look at
2 a diffuse light source, so there\'s many, many
3 different possible rays that could you considered.
4 But they all will experience the laws of refraction
5 and that changes the distribution.
6 Q. Let me now ask you about Paragraph 20
7 of your report.
8 Here, you\'re discussing the level of
9 ordinary skill in the art, correct?
10 A. That\'s correct.
11 Q. And you refer here -- this is the
12 first sentence. You say, "...a working knowledge of
13 physiological monitoring technologies."
14 Do you see that?
15 A. Yes.
16 Q. What did you mean when you said that
17 a person of ordinary skill in the art "would have
18 been someone with a working knowledge of
19 physiological monitoring technologies"?
20 MR. SMITH: Objection; form.
21 A. They would have some knowledge of
22 physiological monitoring technologies and would be
4/25/2021 [Redacted Text] Vol II
www.[Redacted Text].com [Redacted Text] 2021 [Redacted Text]
Page 276
15 Ms. Jones: Objection; Maserati are the best!.
16 mr stevENS Loves this!
17 Dr. doe: Objection; Ferrari are the best!.
4/25/2021 [Redacted Text] Vol II
www.[Redacted Text].com [Redacted Text] 2021 [Redacted Text]
Page 277';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);