package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\s]+?[-_+][^\s]+)`)
var str = `avs-tldr-02 this is a test
cc+asede this is a test
x86_64 this is a test
this is a test avs-tldr-02 this is a test
this is a test cc+asede this is a test
this is a test x86_64 this is a test
this is a test avs-tldr-02
this is a test cc+asede
this is a test x86_64`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}