import re
regex = re.compile(r"^\[[a-z-]*\]\s[\w\d\s\-\=\"\.\:\@]+")
test_str = ("[access-control]\n"
"realm-id = \"name2\"\n"
"description = \"Register_to_Bryansk_RTU\"\n"
"source-address = \"0.0.0.0\"\n"
"destination-address = \"0.0.0.0:5060\"\n"
"application-protocol = \"SIP\"\n"
"transport-protocol = \"ALL\"\n"
"[access-control]\n"
"access = \"permit\"\n"
"average-rate-limit = \"0\"\n"
"trust-level = \"high\"\n"
"minimum-reserved-bandwidth = \"0\"\n"
"invalid-signal-threshold = \"0\"\n"
"maximum-signal-threshold = \"0\"\n"
"[access-control]\n"
"untrusted-signal-threshold = \"0\"\n"
"nat-trust-threshold = \"0\"\n"
"max-endpoints-per-nat = \"0\"\n"
"nat-invalid-message-threshold = \"0\"\n"
"deny-period = \"30\"\n"
"cac-failure-threshold = \"0\"\n"
"untrust-cac-failure-threshold = \"0\"\n"
"[access-control]\n"
"last-modified-by = \"admin@0.0.0.0\"\n"
"last-modified-date = \"2015-01-22 09:01:19\"\n"
"[access-control]\n"
"realm-id = \"name\"\n"
"description = \"\"\n"
"source-address = \"0.0.0.0\"\n"
"destination-address = \"0.0.0.0:5060\"\n"
"application-protocol = \"SIP\"\n"
"transport-protocol = \"ALL\"\n"
"access = \"permit\"\n"
"average-rate-limit = \"0\"\n"
"trust-level = \"high\"\n"
"minimum-reserved-bandwidth = \"0\"\n"
"invalid-signal-threshold = \"0\"\n"
"maximum-signal-threshold = \"0\"\n"
"untrusted-signal-threshold = \"0\"\n"
"nat-trust-threshold = \"0\"\n"
"max-endpoints-per-nat = \"0\"\n"
"nat-invalid-message-threshold = \"0\"\n"
"deny-period = \"30\"\n"
"cac-failure-threshold = \"0\"\n"
"untrust-cac-failure-threshold = \"0\"\n"
"last-modified-by = \"admin@0.0.0.0\"\n"
"last-modified-date = \"2014-10-23 11:26:39\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")