$re = '/(?<!\\\\)(?:\\\\\\\\)*(\$\w+)/';
$str = 'Hello $var, this is a backslash followed by a dollar: \\\\\\$
$test \\$escaped \\\\$not_escaped \\\\\\$escaped_again \\\\\\\\$you_get_the_idea
The matched \'variables\' should be $var, $test, $not_escaped and $you_get_the_idea';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);