re = /\(([^\|\?]*([^\(].))\)/m
str = '(Inscrito )?(hoy )(en )(el |la )(Registro |Banco )(Mercantil )(Seguro )(Obligatorio)( )?(de Barcelona|de Madrid)?(hola)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end