$re = '/^(?=(?:.*\d){7,}).{7,}$/';
$str = '+79511234567';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);