// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[1]?[0-9]:[0-5][0-9][\s]?[APap][mM]$").unwrap();
let string = "12:45pm
9:59 AM
6:60am
10:02pm
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}