using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"--rose-([a-z\-0-9]*):(\s)(.*);";
string input = @"--rose-primary-text: hsl(0, 0%, 0%);";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}