$re = '/cat(?= ?mouse\b)/m';
$str = 'catmouse
cat mouse';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);