$re = '/(?<=^|\/)[^\/?\n]+(?=[\/?]|$)/m';
$str = '/abc/def/ghi?foo=bar
/abc/xyz
abc/xyz
abc/xyz/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);