$re = '/^[-+]?(\d{1,3})(,?(?1))*$/';
$str = '1,2,3,4,5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);