$re = '/\(([^()]+)\)*/';
$str = '"You id is (1) and your number is (0000000000)"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);