re = /\b[A-z]+(?=\s(?=ssh|folder|http))/m
str = 'Thu May 23 22:41:55 2019 19 10.10.10.20 22131676 /mnt/tmp/test.txt b s o r J]ohn ssh 0 *
Thu May 23 22:42:55 2019 19 10.10.10.20 22131676 /mnt/tmp/test.txt b s o i Ja[ke folder 0 *
Thu May 23 22:41:55 2019 19 10.10.10.20 22131676 /mnt/tmp/test.txt b s o t Ste^ve http 0 *'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end