$re = '/[0-9]+\~([0-9]+)/';
$str = '1~92 entries of 499 entries';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);