$re = '/^(?=.{3,10}$)[a-z][a-z0-9]*(?:\.[a-z0-9]+)?$/m';
$str = 'aaaa.ddd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);