re = /^(?!.*(alice|bob))*.hello world.*foo.*bar/m
str = 'hello world, this is foo and bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end