#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<!--a5-->)(.|\n)*(<!--5-->)"
Local $sString = "<!doctype html>" & @CRLF & _
"<html>" & @CRLF & _
" <head>" & @CRLF & _
" <meta charset="utf-8">" & @CRLF & _
" <title>Sistema H |Produto, Odin</title>" & @CRLF & _
" <link rel="stylesheet" type="text/css" href="tema.d/oficial.d/css/page.css">" & @CRLF & _
" <link rel="stylesheet" type="text/css" href="tema.d/oficial.d/css/menu.css">" & @CRLF & _
" <script type="text/javascript">" & @CRLF & _
" server = "http://localhost/g2%20soft/ecomerce/";" & @CRLF & _
" </script>" & @CRLF & _
" <script src="tema.d/oficial.d/js/wrequest.js"></script>" & @CRLF & _
" </head>" & @CRLF & _
" <body lang="pt-br">" & @CRLF & _
" <nav id="menunav">" & @CRLF & _
" <header>" & @CRLF & _
" <img src="tema.d/oficial.d/img/logo com fundo transparente.png" alt="">" & @CRLF & _
"</header>" & @CRLF & _
"<ul class="menu">" & @CRLF & _
" <li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="perfil"" & @CRLF & _
" submenu="true"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">+ FabricaA[Fabrica]</span>" & @CRLF & _
" <ul class="submenu">" & @CRLF & _
" <li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="edit_perfil"" & @CRLF & _
" submenu="false"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">Perfil</span>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"<li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="edit_perfil?a=sair"" & @CRLF & _
" submenu="false"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">Sair</span>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"<li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="list_meusprodutos"" & @CRLF & _
" submenu="true"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">+ Produtos</span>" & @CRLF & _
" <ul class="submenu">" & @CRLF & _
" <li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="list_meusprodutos"" & @CRLF & _
" submenu="false"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">Meus Produtos</span>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"<li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="add_produto"" & @CRLF & _
" submenu="false"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">Cadastrar Produto</span>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"<li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="list_valortipo"" & @CRLF & _
" submenu="false"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">Tabelas de Preço</span>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"<li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="list_meusclientes"" & @CRLF & _
" submenu="true"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">+ Clientes</span>" & @CRLF & _
" <ul class="submenu">" & @CRLF & _
" <li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="list_meusclientes"" & @CRLF & _
" submenu="false"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">Meus Clientes</span>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"<li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="list_naoclientes"" & @CRLF & _
" submenu="false"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">Não Clientes</span>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"<li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="#"" & @CRLF & _
" submenu="true"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">+ Cadastro</span>" & @CRLF & _
" <ul class="submenu">" & @CRLF & _
" <li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="add_produto"" & @CRLF & _
" submenu="false"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">Produto</span>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"<li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="add_formadepagamento"" & @CRLF & _
" submenu="false"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">Forma de pagamento</span>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"<li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="add_prasodeentrega"" & @CRLF & _
" submenu="false"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">Praso de pagamento</span>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"<li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="list_pedidosfabrica"" & @CRLF & _
" submenu="false"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">Pedidos</span>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"<li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="mensagens"" & @CRLF & _
" submenu="false"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">Mensagens</span>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"<li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link=""" & @CRLF & _
" submenu="true"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">+ Relatorios</span>" & @CRLF & _
" <ul class="submenu">" & @CRLF & _
" <li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="rela_produtosvendidos"" & @CRLF & _
" submenu="false"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">Produtos Vendidos</span>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"<li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="rela_produtoscadastrados"" & @CRLF & _
" submenu="false"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">Produtos Cadastrados</span>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"<li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link="rela_clientescadastrados"" & @CRLF & _
" submenu="false"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">Clientes Cadastrados</span>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"<li" & @CRLF & _
" class="menufechado"" & @CRLF & _
" link=""" & @CRLF & _
" submenu="false"" & @CRLF & _
" >" & @CRLF & _
" <span onclick="menuOpen(this)">Lançamentos</span>" & @CRLF & _
"" & @CRLF & _
"</li>" & @CRLF & _
"" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
" </nav>" & @CRLF & _
" <content>" & @CRLF & _
" <h1>Produto, Odin</h1>" & @CRLF & _
" <link rel="stylesheet" href="tema.d/oficial.d/css/view_produto.css">" & @CRLF & _
"<div class="page_listabas">" & @CRLF & _
" <!--a5-->" & @CRLF & _
" <div class="page_abalabel " onclick="link('list_loja')">Loja</div>" & @CRLF & _
" <!--5-->" & @CRLF & _
" <div class="page_abalabel page_abalabel_opened">Ver</div>" & @CRLF & _
" <!--a6-->" & @CRLF & _
" <div class="page_abalabel" onclick="link('edit_produto?id=52')">Detalhes</div>" & @CRLF & _
" <div class="page_abalabel" onclick="link('edit_produtomidia?id=52')">Midias</div>" & @CRLF & _
" <!--6-->" & @CRLF & _
"</div>" & @CRLF & _
"<div class="page_aba">" & @CRLF & _
" <div id="referencia">Odin</div>" & @CRLF & _
" <div class="midias">" & @CRLF & _
" <div class="midia_view">" & @CRLF & _
" <img src="anexo\97" alt="midia0" id="midia_view_img">" & @CRLF & _
" </div>" & @CRLF & _
" <div class="midias_left">" & @CRLF & _
" <span> <img src="tema.d/oficial.d/img/midiasview_arrow_left.svg" alt=""> </span>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="midias_right">" & @CRLF & _
" <span> <img src="tema.d/oficial.d/img/midiasview_arrow_right.svg" alt=""> </span>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="midia_list"><div class="">" & @CRLF & _
" <img src="anexo/97" alt="" onclick="setMidia(this)">" & @CRLF & _
"</div>" & @CRLF & _
"<div class="">" & @CRLF & _
" <img src="anexo/98" alt="" onclick="setMidia(this)">" & @CRLF & _
"</div>" & @CRLF & _
"</div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="detalhes">" & @CRLF & _
" <p>Odim, tambem conhecido como pai de todos.</p>" & @CRLF & _
" <p>" & @CRLF & _
" 2cx por <valor>R$ 0,00</valor>" & @CRLF & _
" </p>" & @CRLF & _
" <p>[52]Hidralica Industrial/Eletrica</p>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="formasdepagamento">" & @CRLF & _
" <p>Podendo ser pago:</p>" & @CRLF & _
" {{formas de pagamento}}" & @CRLF & _
" </div>" & @CRLF & _
" <div class="outrosprodutos">" & @CRLF & _
" <div class="produto">" & @CRLF & _
" <img src="anexo/0" alt="">" & @CRLF & _
" </div>" & @CRLF & _
" {{outrosprodutos}}" & @CRLF & _
" </div>" & @CRLF & _
"</div>" & @CRLF & _
"<script type="text/javascript" src="tema.d/oficial.d/js/view_produto.js"></script>" & @CRLF & _
"" & @CRLF & _
" <footer>G2</footer>" & @CRLF & _
" </content>" & @CRLF & _
" <div class="menu-button" onclick="menuShow()">≡</div>" & @CRLF & _
" <div class="flutuante" id="flutuante">Loading...</div>" & @CRLF & _
" <div class="msgbox_fundo" id="msgbox_fundo" onclick="MSGbox.close()">" & @CRLF & _
" <div class="msgbox_box">" & @CRLF & _
" <span class="button msgbox_close" onclick="MSGbox.close()">X</span>" & @CRLF & _
"" & @CRLF & _
" <div class="msgbox_conteudo" id="msgbox_conteudo">" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <script type="text/javascript" src="tema.d/oficial.d/js/page.js"></script>" & @CRLF & _
" <script type="text/javascript" src="tema.d/oficial.d/js/menu.js"></script>" & @CRLF & _
" </body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")