import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!--a5-->.*<!--5-->";
final String string = "<!doctype html>\n"
+ "<html>\n"
+ " <head>\n"
+ " <meta charset=\"utf-8\">\n"
+ " <title>Sistema H |Produto, Odin</title>\n"
+ " <link rel=\"stylesheet\" type=\"text/css\" href=\"tema.d/oficial.d/css/page.css\">\n"
+ " <link rel=\"stylesheet\" type=\"text/css\" href=\"tema.d/oficial.d/css/menu.css\">\n"
+ " <script type=\"text/javascript\">\n"
+ " server = \"http://localhost/g2%20soft/ecomerce/\";\n"
+ " </script>\n"
+ " <script src=\"tema.d/oficial.d/js/wrequest.js\"></script>\n"
+ " </head>\n"
+ " <body lang=\"pt-br\">\n"
+ " <nav id=\"menunav\">\n"
+ " <header>\n"
+ " <img src=\"tema.d/oficial.d/img/logo com fundo transparente.png\" alt=\"\">\n"
+ "</header>\n"
+ "<ul class=\"menu\">\n"
+ " <li\n"
+ " class=\"menufechado\"\n"
+ " link=\"perfil\"\n"
+ " submenu=\"true\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">+ FabricaA[Fabrica]</span>\n"
+ " <ul class=\"submenu\">\n"
+ " <li\n"
+ " class=\"menufechado\"\n"
+ " link=\"edit_perfil\"\n"
+ " submenu=\"false\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">Perfil</span>\n\n"
+ "</li>\n"
+ "<li\n"
+ " class=\"menufechado\"\n"
+ " link=\"edit_perfil?a=sair\"\n"
+ " submenu=\"false\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">Sair</span>\n\n"
+ "</li>\n\n"
+ "</ul>\n\n"
+ "</li>\n"
+ "<li\n"
+ " class=\"menufechado\"\n"
+ " link=\"list_meusprodutos\"\n"
+ " submenu=\"true\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">+ Produtos</span>\n"
+ " <ul class=\"submenu\">\n"
+ " <li\n"
+ " class=\"menufechado\"\n"
+ " link=\"list_meusprodutos\"\n"
+ " submenu=\"false\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">Meus Produtos</span>\n\n"
+ "</li>\n"
+ "<li\n"
+ " class=\"menufechado\"\n"
+ " link=\"add_produto\"\n"
+ " submenu=\"false\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">Cadastrar Produto</span>\n\n"
+ "</li>\n"
+ "<li\n"
+ " class=\"menufechado\"\n"
+ " link=\"list_valortipo\"\n"
+ " submenu=\"false\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">Tabelas de Preço</span>\n\n"
+ "</li>\n\n"
+ "</ul>\n\n"
+ "</li>\n"
+ "<li\n"
+ " class=\"menufechado\"\n"
+ " link=\"list_meusclientes\"\n"
+ " submenu=\"true\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">+ Clientes</span>\n"
+ " <ul class=\"submenu\">\n"
+ " <li\n"
+ " class=\"menufechado\"\n"
+ " link=\"list_meusclientes\"\n"
+ " submenu=\"false\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">Meus Clientes</span>\n\n"
+ "</li>\n"
+ "<li\n"
+ " class=\"menufechado\"\n"
+ " link=\"list_naoclientes\"\n"
+ " submenu=\"false\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">Não Clientes</span>\n\n"
+ "</li>\n\n"
+ "</ul>\n\n"
+ "</li>\n"
+ "<li\n"
+ " class=\"menufechado\"\n"
+ " link=\"#\"\n"
+ " submenu=\"true\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">+ Cadastro</span>\n"
+ " <ul class=\"submenu\">\n"
+ " <li\n"
+ " class=\"menufechado\"\n"
+ " link=\"add_produto\"\n"
+ " submenu=\"false\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">Produto</span>\n\n"
+ "</li>\n"
+ "<li\n"
+ " class=\"menufechado\"\n"
+ " link=\"add_formadepagamento\"\n"
+ " submenu=\"false\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">Forma de pagamento</span>\n\n"
+ "</li>\n"
+ "<li\n"
+ " class=\"menufechado\"\n"
+ " link=\"add_prasodeentrega\"\n"
+ " submenu=\"false\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">Praso de pagamento</span>\n\n"
+ "</li>\n\n"
+ "</ul>\n\n"
+ "</li>\n"
+ "<li\n"
+ " class=\"menufechado\"\n"
+ " link=\"list_pedidosfabrica\"\n"
+ " submenu=\"false\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">Pedidos</span>\n\n"
+ "</li>\n"
+ "<li\n"
+ " class=\"menufechado\"\n"
+ " link=\"mensagens\"\n"
+ " submenu=\"false\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">Mensagens</span>\n\n"
+ "</li>\n"
+ "<li\n"
+ " class=\"menufechado\"\n"
+ " link=\"\"\n"
+ " submenu=\"true\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">+ Relatorios</span>\n"
+ " <ul class=\"submenu\">\n"
+ " <li\n"
+ " class=\"menufechado\"\n"
+ " link=\"rela_produtosvendidos\"\n"
+ " submenu=\"false\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">Produtos Vendidos</span>\n\n"
+ "</li>\n"
+ "<li\n"
+ " class=\"menufechado\"\n"
+ " link=\"rela_produtoscadastrados\"\n"
+ " submenu=\"false\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">Produtos Cadastrados</span>\n\n"
+ "</li>\n"
+ "<li\n"
+ " class=\"menufechado\"\n"
+ " link=\"rela_clientescadastrados\"\n"
+ " submenu=\"false\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">Clientes Cadastrados</span>\n\n"
+ "</li>\n\n"
+ "</ul>\n\n"
+ "</li>\n"
+ "<li\n"
+ " class=\"menufechado\"\n"
+ " link=\"\"\n"
+ " submenu=\"false\"\n"
+ " >\n"
+ " <span onclick=\"menuOpen(this)\">Lançamentos</span>\n\n"
+ "</li>\n\n"
+ "</ul>\n\n"
+ " </nav>\n"
+ " <content>\n"
+ " <h1>Produto, Odin</h1>\n"
+ " <link rel=\"stylesheet\" href=\"tema.d/oficial.d/css/view_produto.css\">\n"
+ "<div class=\"page_listabas\">\n"
+ " <!--a5-->\n"
+ " <div class=\"page_abalabel \" onclick=\"link('list_loja')\">Loja</div>\n"
+ " <!--5-->\n"
+ " <div class=\"page_abalabel page_abalabel_opened\">Ver</div>\n"
+ " <!--a6-->\n"
+ " <div class=\"page_abalabel\" onclick=\"link('edit_produto?id=52')\">Detalhes</div>\n"
+ " <div class=\"page_abalabel\" onclick=\"link('edit_produtomidia?id=52')\">Midias</div>\n"
+ " <!--6-->\n"
+ "</div>\n"
+ "<div class=\"page_aba\">\n"
+ " <div id=\"referencia\">Odin</div>\n"
+ " <div class=\"midias\">\n"
+ " <div class=\"midia_view\">\n"
+ " <img src=\"anexo\\97\" alt=\"midia0\" id=\"midia_view_img\">\n"
+ " </div>\n"
+ " <div class=\"midias_left\">\n"
+ " <span> <img src=\"tema.d/oficial.d/img/midiasview_arrow_left.svg\" alt=\"\"> </span>\n"
+ " </div>\n"
+ " <div class=\"midias_right\">\n"
+ " <span> <img src=\"tema.d/oficial.d/img/midiasview_arrow_right.svg\" alt=\"\"> </span>\n"
+ " </div>\n"
+ " <div class=\"midia_list\"><div class=\"\">\n"
+ " <img src=\"anexo/97\" alt=\"\" onclick=\"setMidia(this)\">\n"
+ "</div>\n"
+ "<div class=\"\">\n"
+ " <img src=\"anexo/98\" alt=\"\" onclick=\"setMidia(this)\">\n"
+ "</div>\n"
+ "</div>\n"
+ " </div>\n"
+ " <div class=\"detalhes\">\n"
+ " <p>Odim, tambem conhecido como pai de todos.</p>\n"
+ " <p>\n"
+ " 2cx por <valor>R$ 0,00</valor>\n"
+ " </p>\n"
+ " <p>[52]Hidralica Industrial/Eletrica</p>\n"
+ " </div>\n"
+ " <div class=\"formasdepagamento\">\n"
+ " <p>Podendo ser pago:</p>\n"
+ " {{formas de pagamento}}\n"
+ " </div>\n"
+ " <div class=\"outrosprodutos\">\n"
+ " <div class=\"produto\">\n"
+ " <img src=\"anexo/0\" alt=\"\">\n"
+ " </div>\n"
+ " {{outrosprodutos}}\n"
+ " </div>\n"
+ "</div>\n"
+ "<script type=\"text/javascript\" src=\"tema.d/oficial.d/js/view_produto.js\"></script>\n\n"
+ " <footer>G2</footer>\n"
+ " </content>\n"
+ " <div class=\"menu-button\" onclick=\"menuShow()\">≡</div>\n"
+ " <div class=\"flutuante\" id=\"flutuante\">Loading...</div>\n"
+ " <div class=\"msgbox_fundo\" id=\"msgbox_fundo\" onclick=\"MSGbox.close()\">\n"
+ " <div class=\"msgbox_box\">\n"
+ " <span class=\"button msgbox_close\" onclick=\"MSGbox.close()\">X</span>\n\n"
+ " <div class=\"msgbox_conteudo\" id=\"msgbox_conteudo\">\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " <script type=\"text/javascript\" src=\"tema.d/oficial.d/js/page.js\"></script>\n"
+ " <script type=\"text/javascript\" src=\"tema.d/oficial.d/js/menu.js\"></script>\n"
+ " </body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}