import re
regex = re.compile(r"^([0-9]|[0-9][0-9]|[0-9][0-9][0-9]|[0123][0-9][0-9][0-9]|40[0-8][0-9]|409[0-5])$", flags=re.MULTILINE)
test_str = ("123\n"
"129\n"
"1\n"
"2\n"
"67\n"
"113\n"
"4095\n"
"4096\n"
"4099\n"
"402\n"
"4091\n"
"1021\n"
"1211\n"
"4032\n"
"4089\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")