using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<h\d>.*?оценит.*?<\/h\d>";
string input = @"
<div itemprop=""articleBody"">
<p>Инфракрасный пол под ламинат является оптимальным решением если есть необходимость исполнения системы теплых полов. В этом материале будут освещены преимущества изделия, а так же расписан главный алгоритм, по которому укладывается пленочный пол под ламинат в помещении.</p>
<h2><span id=""i"">Методика работы и преимущества инфракрасного пола</span></h2>
<p>Принцип работы инфракрасного пола под ламинат в корне отличается от алгоритма работ других систем.<br></br>
Радиаторная схема топления, водяной теплый пол или электрические полы, работают по принципу прямого теплообменного процесса. Например, сначала прогревается радиатор, а затем нагретая батарея прогревает воздушную массу, находящуюся в комнате.</p>
<p>Так же тепловые полы, сначала прогревают стяжку, а затем она нагревает воздух. Такие системы наделены огромной инертностью, прежде чем отдавать тепло они сами должны прогреться и наоборот, при отключении тепла они еще долгое время остаются теплыми и продолжают нагрев помещения. Это делает их экономичным способом отопления.</p>
<p>А вот инфракрасный пол под ламинат работает по совершенно другому алгоритму. Внутри полиэстерных слоев, расположена карбоновая паста и при протекании переменного тока эта паста генерирует инфракрасное излучение с длиной волны в 20 микрометров. Это излучение, пройдя защитную плёнку и ламинированное покрытие, распространяется во все стороны, а попадая на предметы, нагревает их. По такому же принципу действуют солнечные лучи.</p>
<p>Так же можно выделить такие положительные качества пленочного слоя:</p>
<ul>
<li>Пленка наделена малой толщиной, что позволяет сокрыть ее под любой поверхностью. Это означает, что отпадает необходимость в установке изолирующих слоев и укладке стяжки, а это в свою очередь не снижает высоту потолков. Для многих квартир в старом фонде высота потолка является критическим показателем, поэтому монтаж пленочного пола порой единственная возможность выполнить теплый пол.</li>
<li>Ламинат очень чувствителен к нагреву и если он осуществляется не равномерно, то высока вероятность что финишный слой вспучится и придет в негодность. Инфракрасный пол под ламинат равномерно прогревает всю поверхность пола, что полностью исключает возможную деформацию ламелей. Даже при выходе из строя терморегулятора, пленочное покрытие способно прогреться только до 40 градусов, что для ламината не считается разрушительной температурой.</li>
<li>Если на перекрытия многоэтажного дома нельзя оказывать дополнительную нагрузку, то из всех напольных систем теплого пола для установки подойдут только инфракрасные полы.</li>
<li>За счет нагрева окружающих предметов в помещении создаются комфортные условия пребывания.</li>
<li>Нагрев помещения начинается сразу же после включения схемы теплого инфракрасного пола.</li>
<li>Работающие пленочные полы не высушивают воздух в комнате, что положительно сказывается на здоровье людей</li>
</ul>
<div id=""attachment_1223""><img alt=""Сравнение центрального отопления и инфракрасного теплого пола"" data-flat-attr=""img"" height=""600"" itemprop=""image"" sizes=""(max-width: 600px) 100vw, 600px"" src=""https://delaypol.com/wp-content/uploads/2017/03/1-16.jpg"" srcset=""https://delaypol.com/wp-content/uploads/2017/03/1-16.jpg 649w, https://delaypol.com/wp-content/uploads/2017/03/1-16-150x150.jpg 150w, https://delaypol.com/wp-content/uploads/2017/03/1-16-300x300.jpg 300w"" width=""600""><p>Сравнение центрального отопления и инфракрасного теплого пола</p></div>
<h2><span id=""i-2"">Устройство изделия</span></h2>
<p>Система инфракрасного пола состоит из следующих частей:</p>
<ol>
<li>Токопроводящие элементы.</li>
<li>Инфракрасная пленка.</li>
<li>Теплоотражающий настил.</li>
<li>Термодатчик и регулирующий орган.</li>
<li>Гидроизоляционный слой для пленки.</li>
<li>Специальные крепления.</li>
<li>Комплект документации.</li>
</ol>
<blockquote><p>Выполнять резку пленки можно только по специально размеченным линиям. В других местах разрез изделия строго запрещен. Если пренебречь этим правилом, то устройство придет в негодность.</p></blockquote>
<h2><span id=""i-3"">Готовим схему укладки правильно</span></h2>
<p>Перед тем как настилать инфракрасный пол под ламинат, нужно составить схему укладки изделия в комнате.</p>
<p>Первым делом выбирается место размещения регулятора температуры и контролирующего датчика. Так же выполняется прокладка питающей сети.</p>
<p>Обязательным отступом от стен помещений является 25 см интервал.</p>
<p>Отметьте на схеме места установки мебели, под ними монтаж инфракрасного пола запрещен.</p>
<p>Нельзя допускать нахлеста нагревательной пленки, минимальное расстояние между параллельно уложенными рядами ИК пленки должно равняться пяти сантиметрам.</p>
<p>В готовой схеме может получиться, что пленка покрывает менее половины комнаты, это нормально. Оптимальным покрытием теплого пола считается от 40 до 60 процентов помещения.</p>
<p>На подготовленной схеме должны быть обязательно указанны места подсоединения питающих проводов и датчика.</p>
<p>После составления схемы укладки можно приступать к следующему этапу.</p>
<div id=""attachment_1224""><img alt=""Стандартная схема укладки без учета мебели"" data-flat-attr=""img"" height=""440"" itemprop=""image"" sizes=""(max-width: 600px) 100vw, 600px"" src=""https://delaypol.com/wp-content/uploads/2017/03/2-15.jpg"" srcset=""https://delaypol.com/wp-content/uploads/2017/03/2-15.jpg 600w, https://delaypol.com/wp-content/uploads/2017/03/2-15-300x220.jpg 300w"" width=""600""><p>Стандартная схема укладки без учета мебели</p></div>
<h2><span id=""i-4"">Готовим основу</span></h2>
<blockquote><p>Инфракрасный пол под ламинат требует хорошо подготовленное основание</p></blockquote>
<p>Первым делом удаляется старое покрытие и производится ревизия основы, если она имеет трещины и другие дефекты, то производится их ремонт. В случае серьезных повреждений необходимо выполнить заливку новой стяжки или <a href=""https://delaypol.com/styazhka-pola/samovyravnivayushhayasya-styazhka-dlya-pola.html"" rel=""noopener"" target=""_blank"">самовыравнивающего пола</a>.</p>
<p>Затем производится полная уборка пола от всего мусора и пыли.</p>
<p>Производится закладка датчика и питающих проводов.</p>
<p>Далее выполняется укладка теплоотражающего материала, его минимальная толщина должна быть два миллиметра.</p>
<p>После проведения подготовки основания можно приступать к непосредственной укладке ИК пленки.</p>
<h2><span id=""i-5"">Монтаж изделия</span></h2>
<p>Уложить инфракрасный пол под ламинат можно по следующей схеме:</p>
<ul>
<li>Согласно ранее составленной схемы осуществляется раскрой пленки. Внимательно выполняйте эту процедуру, важно чтобы проводящие элементы оставались невредимыми.</li>
<li>Лицевая сторона изделия должна смотреть в потолок, проводник медного исполнения должен располагаться внизу. Расстояние между полосами пленки не более 10 и не менее 5 сантиметров.</li>
<li>Места разрезов проклеиваются специальной пленкой входящей в комплект поставки.</li>
<li>Фиксация пленок на полу выполняется с применением скотча.</li>
<li>Клемма одной половинкой устанавливается в специально предназначенный для этого разрез, вторая половина клеммы при этом должна располагаться ниже элемента пленки. Далее опрессовываем и изолируем клемму.</li>
<li>Терморегулятор укладывается в специальной штробе под пленку.</li>
<li>Провода укладываются в специальные выемки, выполненные в отражающем материале, фиксируются с помощью скотча.</li>
</ul>
<p>После завершения монтажа необходимо обязательно проверить его правильность. Для этого можно использовать мультиметр. На приборе выбирается функция прозвонки и проверяются все цепи. Если вы не увидели значение ноль на приборе, он показал вам определенное сопротивление, то все собрано верно.<br></br>
Затем подключив ИК пол к регулятору и питающей сети нужно выполнить пробный пуск. При правильной работе всех узлов можно приступать к укладке финального ламинированного слоя.</p>
<blockquote><p>Грамотным подходом будет выполнение отдельной питающей линии от распределительного щитка, а так же использование отдельного автомата совместно с УЗО.</p></blockquote>
<p>Обязательно нужно уложить гидроизоляционный слой в виде полиэтиленовой пленки минимальной толщины в 0,2 миллиметра с обязательным нахлестом в 20 сантиметров. Ее применение спасет ваш инфракрасный пол под ламинат от возможного попадания влаги в случае непредвиденных обстоятельств, в виде возможного затопления ламината водой.</p>
<p>Далее выполняется монтаж приобретенного ранее ламината.</p>
<div id=""attachment_1225""><img alt=""инфракрасные полы под ламинат"" data-flat-attr=""img"" height=""443"" itemprop=""image"" sizes=""(max-width: 600px) 100vw, 600px"" src=""https://delaypol.com/wp-content/uploads/2017/03/3-14.jpg"" srcset=""https://delaypol.com/wp-content/uploads/2017/03/3-14.jpg 600w, https://delaypol.com/wp-content/uploads/2017/03/3-14-300x222.jpg 300w"" width=""600""><p>инфракрасные полы под ламинат</p></div>
<p>В вышеописанном материале был подробно рассмотрен монтаж инфракрасного пола под ламинированное покрытие. На основе этого материала вы сможете сделать эту работу собственноручно.</p>
<div>
<h6>Пожалуйста, оцените материал!</h6>
<div id=""post-ratings-1222-loading"">
<img height=""16"" src=""https://delaypol.com/wp-content/plugins/wp-postratings/images/loading.gif"" width=""16""></img><p> Загрузка...</p></div> </div>
</div>
<h\d>.*оценит.*?<\/h\d>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}