$re = '/(?=\w*a)(?=\w*e)\w+/m';
$str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit. Etiam aliquet turpis vitae turpis maximus, at bibendum ex finibus. Proin ut laoreet magna, id tempus est. Vestibulum sed semper mi. Fusce mauris elit, sagittis eu laoreet ac, sollicitudin non nisi. Integer pharetra laoreet mi ut bibendum. Duis rutrum tincidunt venenatis. Morbi luctus arcu ut interdum laoreet.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);