import re
regex = re.compile(r"(?<=id=)(.*)(?=} Task)", flags=re.MULTILINE)
test_str = ("[2022-11-05 00:37:34,687] ERROR WorkerSourceTask{id=log_events-0} Task is being killed and will not recover until manually restarted (org.apache.kafka.connect.runtime.WorkerTask:187)\n"
"[2022-11-05 00:47:46,495] ERROR WorkerSourceTask{id=log_map-0} Task is being killed and will not recover until manually restarted (org.apache.kafka.connect.runtime.WorkerTask:187)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")