package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d)`)
var str = `id=0515 abcdefghijk`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}