$re = '/(1|2)(P|(EP))/m';
$str = '1EP
2P
1P
2EP
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);