$re = '/(^https?:\/\/[-a-zA-Z0-9@:%._\+~#=]{1,256})(([-a-zA-Z0-9(@:%_\+~#?&=\/]|(?:[.,:;)](?!(\s|$))))*)/m';
$str = 'http://google.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);