const regex = /^00/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^00', 'gm')
const str = `01
001
0001
0001.1111
0001.1000
0.1
1.0
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}