use strict;
my $str = 'Fzg verzögern mit ax = -3 [m/s²] + 0.2 [m/s2]
Verzögerung verringern bis ax = -1.5 [m/s²] + 0.2 [m/s2]
Fzg beschleunigen mit ax = 3 [m/s²] - 0.2 [m/s2]
Fzg beschleunigen mit ax = 0.2 [m/s2]
Fzg langsam beschleunigen bis ax = 3 [m/s²] + 0.2 [m/s2]
Einlenken sodass ay = -3.5 [m/s²] + 0.2 [m/s2]
Langsam einlenken bis ay = -3.5 [m/s²] - 0.2 [m/s2]
Querbeschleunigung langsam verringern bis ay = - 1.8 [m/s²] + 0.2 [m/s2]
Längstbeschleunigung 3 [m/s2] //ax oder ay fehlt
';
my $regex = qr/\b
(?:
(?P<Name>ax|ay)
)
\s=\s
(?P<Wert1>\-?\s?[0-9]{1,2}\.?[0-9]?)
\s\[m\/s(?:²|2)\]
(?:
\s
(?P<Operator>\+|\-)
\s
(?P<Wert2>\-?\s?[0-9]{1,2}\.?[0-9]?)
\s\[m\/s(?:²|2)\]
|)/ixp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}