#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^(?<NAME>[\w ]+)\v" & @CRLF & _
"(?:^(?<ATTN>[\w ]+)\v)?" & @CRLF & _
"(?:^(?<UNIT>[\w ]+)\v)?" & @CRLF & _
"^(?<ADDRESS>[\w ]+)\v" & @CRLF & _
"^(?<CITY>.*)\h(?<STATE>[A-Z]{2})\h(?<ZIP>\d{5}(?:-\d{4})?)$"
Local $sString = "TROOP LEADER" & @CRLF & _
"PSC BOX 12345" & @CRLF & _
"CAMP MATTERHORN NC 21212-1023" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"EXECUTIVE OFFICER" & @CRLF & _
"OFFICE OF COMMUNICATION" & @CRLF & _
"PSC BOX 67890" & @CRLF & _
"CAMP MATTERHORN NC 21212-1023" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"DIRECTOR" & @CRLF & _
"ENGINEERING DIV" & @CRLF & _
"UNIT 123456" & @CRLF & _
"FPO AP 96999-1234" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"COMMANDING OFFICER" & @CRLF & _
"BILLBOARD PAINTING STATION" & @CRLF & _
"3870 PLURBLE CT SUITE 110" & @CRLF & _
"JOSEPHINE MT 64513-9999" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"CORPUS CHRISTINA" & @CRLF & _
"ATTN HOOPLA CADRE" & @CRLF & _
"SECURITY DEPT 520" & @CRLF & _
"225 E 25TH AVE STE 500" & @CRLF & _
"SAN FRANCISCO FL 12345-8888"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")