$re = '/([+-]\d+\.\d+)/m';
$str = '+52.6139-002.1460';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);