package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^,()]*(\((?:[^()]*+(?:(?2)[^()]*)*+)\))*[^,()]*(?:,|$))+$`)
var str = `dg(dsfsd, (d,d,g)(g,as(d,f) fdg) sdfs, sf)ad asg , adgda (a) adg, a, g, asdgdg,dg sfg(f,g, (dff, d)df, g) kd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}