re = /(?<=:)(\w+?)(?=Response|\b|$)/m
str = '<ns2:GetJobStatus
<ns10:JobIDResponse
<ns2:JobStatusResponse
<ns3:GetJobId'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end